The incident has been resolved and all the systems are back to normal.
Posted May 14, 2025 - 07:55 PDT
Monitoring
We have implemented a fix and all the systems are back to normal now. We are monitoring the systems currently.
Posted May 14, 2025 - 07:22 PDT
Investigating
The issue is still being investigated and we optimising systems. Campaign Delivery and Data exports are still impacted. Please expect the next update in 45 minutes.
Posted May 14, 2025 - 05:30 PDT
Identified
We have identified the issue and are working on the fix. Login issue has been resolved. At the moment, impacted components are campaign delivery and Data exports.
Posted May 14, 2025 - 04:35 PDT
Investigating
We are investigating reports of Dashboard Login issues and query failures impacting our accounts within the EU region. Data ingestion from both API and SDK is processing with delays for these accounts. Please expect an update within 30 - 45 minutes.
Posted May 14, 2025 - 04:17 PDT
This incident affected: Europe (API Ingestion, SDK Ingestion, SFTP Imports, Dashboard Reports, Campaign Delivery, Data Exports).